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Chapter 1 .
Using Graphic Editor

Introduction

WebShop’s Graphic Editor module is one of its most important features.  Understanding the
windows, toolbars, and buttons can make using the application quick and efficient.

Topics covered in this chapter include:
• Launching Graphic Editor
• Graphics Editor Functions
• Graphics Editor Window (Full Edit)
• Page Editor Window (“In-Place” Edit)
• Graphic Editor Toolbars

Launching Graphic Editor
To launch the WebShop’s Graphic Editor module you must specify which image resource file
you want to open.  There are two ways to open the Graphic Editor:  (1) from the Site Manager–
Physical Layout window (where you select the image file from the resource tree), or (2) from an
open Web page in Page Editor (where you select an image that has been placed on the page).

To open Graphic Editor from Site Manager–Physical Layout
• Double-click on an Image File icon from the resource tree.  Graphic Editor opens and the

image is placed in the image worksheet area.  The image is now ready to be edited.

To open Graphic Editor from a Web page in Page Editor

1. From Site Manager–Logical Layout , double-click on a Web Page that contains a graphic
image.  The selected page opens in Page Editor.
Note:  A graphic image is any image that has been inserted using Insert > Image, or by
clicking the Image button on the Insert Object toolbar.

2. Click on the image that you want to edit and select Format > Object > Edit  or right-click
and select Object > Edit .
Note:  The Graphic Editor Window uses the title: “WebShop <CNQ file name> - Web Site -
<image file name>”.  This naming convention emphasizes that images are resources to
specific project files.
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Graphic Editor Functions

Use Graphic Editor to insert or edit the following graphic objects:  Text Line , Image , Fill
Pattern , Border , Paragraph Text , Calendar , Chart , OLE, and Drawing .  You will also use
Graphic Editor to assign image map links and convert graphic objects or images into template
placeholders.

To perform any of these operations, an image resource file must be created.  Normally, you
create and place an image resource file on your Web page prior to editing or inserting a graphic
object.  When you create an image resource file that is empty and place it on a Web page, you
are inserting a blank image file.

To insert a blank image file onto a Plain Page
1. Double-click on a Plain Page  icon from Site Manager–Logical Layout .  The Page Editor

window appears.
2. Select Insert > Image  or click Image on the New Object toolbar.  The Image Attributes

dialog box appears.
3. Click Create .  A new image file is added to existing resource and is already selected for

you.  Click OK.  The selected blank image file is inserted.  An image bounding box appears
with the words “Blank Image .”

Note:  By default blank images are created with a height and width of 100 pixels and are
formatted as GIF files with 256 colors.  The background is set to be the same as the Graphic
Editor worksheet (this is not necessarily the same as the Web Page background).  All of
these defaults settings can be changed by selecting the image and clicking the Page Setup
button on the Main toolbar.  The Image Properties dialog box appears.

Graphic Editor Modes
You can open Graphic Editor from either one of two modes:

••••• Full Edit Mode .  Makes all Graphic Editor features available and allows you to insert any
graphic object.  When you are in Full Edit Mode the Graphic Editor window opens.  All
Control toolbar options are available and the image pasteboard area is visible.

••••• “In-place” Edit Mode .  Makes available most Graphic Editor features.  In-Place edit allows
you to see the rest of your Web Page content while you update a blank or existing image
file.  The Graphic Editor window does not open.  During “in-place” edits, your screen
display remains in Page Editor.  The Menu bar options, however, change and most of the
Graphic Editor toolbars become available.  The image pasteboard area is not available.  All
objects must be inserted directly into the Image bounding box.

Normal or Template Placeholder Form
Objects placed either in the Graphic Editor window or on a Web page can be displayed in either
Normal or Template Placeholder form.  Normal objects are displayed as exact images (or
objects).  Template Placeholders are displayed as a programming representations that will be
updated later.
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To display a graphic object in placeholder form from Page Editor
1. Right-click a Normal object.  A pop-up menu appears.
2. Select Show > As Placeholder .  The object appears in Placeholder form.

When displayed as a placeholder, an object will have a colored box and a small symbol repre-
senting the type of object.  This small symbol correlates with the Insert Object buttons on the
Insert Object toolbar.  When you convert a Normal object into a placeholder, the representative
symbol is placed in the corner of the bounding box (that is, a box around the object area).  Each
object type has its own color.  The color code for the objects that can be made into placeholders
is as follows:

••••• Text Line - blue

••••• Image - red

••••• Fill Pattern - cyan

••••• Border - yellow

••••• Paragraph Text - bright green

••••• Calendar - pink

••••• Chart - olive

••••• OLE - teal

Note:  For more information about templates and placeholders, see the chapter titled
“Creating WebShop Templates.”

Graphic Editor Window (Full Edit)

In Full Edit mode (Figure 1.1), the Graphic Editor window has several elements:

••••• Title bar .  Indicates the CNQ file that is open and the Image file that is open.  The naming
convention used in the title bar is “WebShop <CNQ file name> - Web Site - <image file
name> ”

••••• Menu bar .  Provides access to WebShop functions.  The menu bar options available in
Graphic Editor are different from those available in Page Editor or Site Manager.  Graphic
Editor Menu options include:  File, Edit, View, Site, Object, Library, Window, and Help.
Additional Menu options become available depending upon the object inserted or selected.
These additional menu options include:

••••• Text Line - Modify, Alignment

••••• Image - Modify

••••• Fill Pattern - Modify

••••• Border - Modify

••••• Paragraph Text - Format, Insert, Effects, Tools

••••• Calendar - Modify

••••• Chart - Modify



Chapter 1. Using Graphic Editor

WebShop 2000 User Guide1–4        ◆   ◆   ◆

GRAPHIC EDITOR

Figure 1.1 – Graphic Editor Window – Full Edit Mode
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••••• OLE - Modify
••••• Drawing - Modify, Create

••••• Main toolbar .  Appears across the top of the Graphic Editor window below the Menu bar.
This toolbar offers quick mouse access to the most basic functions, such as Save, Cut,
Paste, and so forth.  This toolbar is common to all WebShop modules.

Note:  The Page Setup button is only available when an image file is being updated.

••••• Control toolbar .  Appears across the top of the Graphic Editor window and gives you
access to object manipulations (move, rotate, distort) and viewing functions, such as zoom
in and zoom out.

••••• New Objects toolbar .  Appears just below the Main toolbar and is used to insert graphic
objects into the Image worksheet area.  There are separate buttons for each graphic object
and for assigning image map links, grouping or ungrouping objects, and others.

••••• Clipart toolbar .  Appears on the right side of the Graphic Editor window and displays one
of several images and image libraries included with WebShop.  To use the Clipart toolbar,
specify the Clipart library and scroll through the images available with that library.  Click
and drag a selected image onto the Graphic Editor window.  You can now manipulate the
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image as usual.

••••• Window toolbar .  Appears near the bottom of the screen and indicates each of the various
project windows are currently open in WebShop.  Use this toolbar to quickly navigate
between different windows.

••••• Help/Status bar .  Appears at the bottom of the Graphic Editor window displays a Help tip
for any toolbar button or menu option.

••••• Ruler .  Appears only when the feature is turned on when you first install the program.

••••• Object Toolbar–Drawing .  Appears only when you insert a Drawing object.  The functions
performed by this toolbar correspond to the Create and Modify menu options, which are
also conditional.

••••• Image Worksheet area .  Appears in the center of the Graphic Editor window.  The Image
worksheet area size is controlled by Image Properties which are defined when the image is
first created.  The size of the Image Worksheet area and size the Image bounding box that
is visible in Page Editor are the same.  When you define the image size using Image
Properties, you also establish the Image Worksheet area.  The default worksheet area color
is specified in Preferences.

WARNING!  Do not use the command Format > Object > Properties to resize an image.
This opens the Image Attributes dialog box.  If you reset the image size from Image At-
tributes you will not be able to access in-place edit.  You can however use Image Attributes
to set up some space around the image, create a simple image border, or specify the
alignment of the image on the Web page.

••••• Pasteboard Area .  Appears all around the Image worksheet area.

Page Editor Window (“In-Place” Edit)

From “In-Place” Edit (Figure 1.2), the Page Editor window has several elements:

••••• Title bar .  Indicates the CNQ file that is open and the Logical name for the Page is open.
The naming convention used in the title bar is “WebShop <CNQ file name> - Web Site -
<logical page name> ”

••••• Menu bar .  Page Editor menu options are replaced with Graphic Editor menu options.
Graphic Editor options are object sensitive.  Depending upon the object inserted, some
options become available while others become unavailable.

••••• Main toolbar .  Appears across the top of the Page Editor window below the Menu bar.

••••• Control toolbar .  Appears next to the Main toolbar.  This is a smaller version of the full
Graphic Editor Control toolbar.

••••• Clipart toolbar .  Appears on the right side of the Page Editor window and displays one of
several images and image libraries included with WebShop.

••••• Window toolbar .  Appears near the bottom of the screen and indicates each of the various
project windows currently open.  This toolbar is unchanged.

••••• Help/Status bar .  Appears at the bottom of the Page Editor window displays a Help tip for
any toolbar button or menu option.  This toolbar is unchanged.

••••• Image Worksheet area .  Appears on the Page Editor window where ever an image is
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placed.  The Image worksheet area size is controlled by Image Properties which are defined
when the image is first created.  When you define the image size using Image Properties
you also establish the Image Worksheet area and the image display area.

••••• Header and Footer objects .  Appears in the Page Editor window whenever a header or
footer is specified.

Note:  The Pasteboard area and the Ruler are not available during “in-place” edits.

Floating Toolbars
Most of the WebShop toolbars can be made to float or be relocated at different locations in the
Page Editor window or in the Graphic Editor window.  A floating toolbar can be moved to any
location for easier access and convenience.  You can dock a floating toolbar by returning it to its
default location or to one of the toolbar locations at the top, bottom, right, or left of a WebShop
window.

To relocate (or undock) a toolbar, double-click in the toolbar area (not inside one of the toolbar
buttons).  The toolbar is immediately undocked.  Place the mouse pointer on the toolbar title bar
and drag it to the position that you want.

Figure 1.2 – Page  Editor Window – “In-Place” Edit  Mode

 Menu Bar Control ToolbarNew Objects Toolbar

Main Toolbar

Title Bar

Clipart Toolbar

Header/Footer AreaWindow Toolbar Help/Status Bar

Image Worksheet Area
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Graphic Editor Toolbars

The following Graphic Editor toolbars are covered:  New Object , Control , each of the seven
Object toolbars, Paragraph Text Formatting , and Clipart .

Note:  All seven of the Object toolbars have the same display name, “Object.”  To identify
them individually, the convention Object Toolbar–“Object Type” is used.  Depending upon the
object selected or inserted, one of the seven Object toolbars appears.

New Object Toolbar
Use the New Object toolbar (Figure 1.3) to initially create a graphic object.  To access this
toolbar highlight an image on a Web page and select Format > Object > Edit .

••••• Text Line .  Inserts a single line of text.  When you select the Text Line  button on the New
Object toolbar, the Text Line dialog box appears.  From this dialog box, you may enter up
to 128 characters of text, select whether to use horizontal or vertical placement, and enter a
specified amount of spacing between characters.  To edit a text line object, use the Object
Toolbar–Text Line or select Modify > Text .  The Object Toolbar–Text Line appears
whenever you insert or select a text line object.  (For more information, see the topic
“Object Toolbars” later in this chapter.)

• Image .  Inserts images into the image worksheet area from a graphic library.  The Image
dialog box appears.  Use this to select a library image or to import an image from your hard
disk.  If you want to replace an image, select Modify > Replace Image  from the Menu bar.

••••• Fill Pattern .  Inserts a fill pattern object that can be resized and placed behind a graphic
object.  The Fill Pattern dialog box appears.  Fill pattern objects provide an easy method
for changing the background of an image.  Fill patterns are separate objects that you select
and manipulate like other graphic objects and can be grouped and layered as necessary.

••••• Border .  Inserts a graphic frame or border that can be place into a WebShop project.  These
graphics differ from some of the other types of Clipart because they have an outside border
with a transparent center.  You can select frames and borders from one of the existing
libraries or create your own.

Once you click the Border button on the New Object toolbar, the Border dialog box
appears.  The available borders are displayed, by library.  Click the Preview check box to
view a selected border in greater detail before inserting it.  If you want to replace a border,

Figure 1.3 – New Object Toolbar
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select Modify > Replace Border from the Menu bar.
• Paragraph Text .  Inserts a paragraph text object into an image resource file so it can be

used with a WebShop project.  Use this button when you want to create a compound image
that will display more than one line of text.

To insert a paragraph text object into a compound image, click Paragraph Text on the New
Object toolbar.  A text box is inserted.  To type the text you want to display, select Format
> Edit Text  or click Edit Text  on the Object Toolbar–Paragraph Text.  The blinking cursor
appears.  Type the text you want.  To exit Paragraph Text edit mode.  Select Format > Edit
Text  or click Edit Text  on the Object Toolbar–Paragraph Text again.  The blinking cursor
disappears.

• Calendar .  Inserts a calendar object into an image resource file.  The Calendar dialog box
appears.  Use this to specify the type of calendar you want.  To insert a calendar onto a
Web page, first create the calendar you want and place the image on to the desired Web
page.  Once placed, resize the image as necessary.  Remember: When you resize an image
you must first resize the image presentation area and then resize the object.  WebShop
supports six calendar types: Yearly, Semiannual, Quarterly, Monthly, Weekly, and Daily.

• Chart .  Inserts a chart object into an image resource file.  The Chart dialog box appears.
Use this to specify the type of chart you want.  To insert a chart onto a Web page, first
create the chart you want and place the image on to the desired Web page.  Once placed,
resize the image as necessary.  Remember: When you resize an image you must first resize
the image presentation area and then resize the object.  WebShop supports twenty-one chart
types, including pie charts, 3D charts, ribbon charts and two-dimensional charts.

••••• OLE.  Inserts an OLE object from an OLE compatible application.  The Insert New Object
dialog box appears.  You can insert an OLE object from your hard disk or create a new one.
You can also choose to display the OLE object as an icon on your Web page.  If you want
to replace or modify an OLE object, select Modify > Edit OLE Object from the Menu bar.

••••• Drawing .  Inserts a Drawing object into an image worksheet area.  The Object Toolbar–
Drawing appears.  To insert an object, select between a rectangle, ellipse and polygon tool.
Place the object and then edit it by changing its shape or by selecting a line and/or fill color.
If you want to delete or resize a Drawing object, select Modify > Edit .  The resize handles
appear.  You may now delete or resize the object.  To edit the object’s nodes, select Modify
> Edit Nodes .  The object nodes appear.  To create an additional object, select Create and
specify the drawing tool you want to use.

••••• Map Link .  Assigns a map link to a portion of a graphic.  The Object Toolbar–Map Link
appears.  This is a modified version of drawing toolbar.  Select the drawing tool you want
to use to define the image map area.  When done, the Link dialog box appears.  Specify the
link.  When done, a secondary toolbar appears for image map editing.  Use this toolbar to
edit the image map area or to edit the assigned image map link.  Use the Create and Modify
menu options as necessary to create additional image map areas or to edit your existing
image map links.

••••• Group/Ungroup .  Groups selected objects together or ungroups them if they are currently
grouped.  This option is only available if more than one image has been selected.

••••• Align & Size .  Opens the Align & Size  dialog box.  This option is only available if one or
more images are selected.  When a single object is selected, the align and size options are
relative to the image worksheet area only.  Alignment options are either horizontal or
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vertical and the resize options are relative to the worksheet height or width.  When an
object group is selected, the align and size options are relative to either the image work-
sheet area or to bounding box created by the objects selected.  Use this option to quickly
align and resize graphic objects within the image worksheet area.

••••• Rotate .  Rotates the selected object using the Rotate dialog box.  There are two ways to
rotate an object:  (1) using the Select Rotate  button on the Control toolbar, or (2) using the
Rotate button on the New Object toolbar.  Select Rotate  allows you to manually rotate the
image with your cursor.  Rotate uses Rotate dialog box.  Specify the number of degree
clockwise that you want to rotate the object.

••••• Modify Shape .  Modifies the shape of the selected object using the Modify Shape dialog
box.  There are two ways to modify the shape of an object:  (1) using the Select Shape
button on the Control toolbar, or (2) using the Modify Shape button on the New Object
toolbar.  Select Shape allows you to manually distort the image with your cursor.  Modify
Shape uses the Modify Shape dialog box.  A list of predefined shapes appears.

Control Toolbar
The Control toolbar (Figure 1.4) is located on the left side of the Graphic Editor window.  This
toolbar includes object orientation and viewing controls.  With them, you can view an object at
different magnifications or change an object’s
orientation.  The toolbar buttons are described
below.
• Select Box .  Selects an object for reposi-

tioning or resizing.  This is the default
operation for the cursor while in Graphic
Editor.  Click on an object to select it.  The
object bounding box and resize handles
appear.  To resize an object, click and drag
one of the resize handles.

• Select Rotate .  Selects an object for manual
rotation using the cursor.  There are two ways to rotate an object:  (1) using the Select
Rotate  button on the Control toolbar, or (2) using the Rotate button on the New Object
toolbar.  Select Rotate  allows you to manually rotate the image with your cursor.  To use
this button, click Select Rotate  and click on the object you wish to rotate.  The object’s
bounding box appears with rotation handles and a center point bullet.  Place your cursor on
one of the bounding box’s corners, click and drag the corner to rotate the object as many
degrees as you want and release the mouse.

Note:  Select Rotate works only with vector graphics, such as Windows Metafile (WMF)
images and other graphic objects, such as text line objects.  The feature does not work with
raster graphics, such as Windows Bitmapped (BMP) and Paint (PCX) files or paragraph text.

Center of Rotation.  Any object can be rotated around a rotation center point.  When you
click Select Rotate  and click on an object, the object’s bounding box appears.  WebShop
places a black bold bullet in the middle of the bounding box.  This is the center point
around which the object is rotated.  Using your mouse, you can drag this center point and
place it anywhere inside or outside the bounding box.  After you reposition the center point,

Figure 1.4 – Control Toolbar
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click and drag any one of the four corners.  The object will be rotated around the new
center point position.

• Select Shape .  Selects an object for manual distortion of the object’s shape using the
cursor.  There are two ways to modify the shape of an object:  (1) using the Select Shape
button on the Control toolbar, or (2) using the Modify Shape button on the New Object
toolbar.  Select Shape allows you to manually distort the image with your cursor.  Modify
Shape uses Modify Shape dialog box with a list of predefined shapes.

To use this feature, click Select Shape  and select the object to be modified.  The object’s
reshaping handles appear.  Click and drag one of the reshaping handles.  WebShop changes
the shape of the object according to how you have distorted the reshaping handle.  Web-
Shop fills the newly “curved” bounding box with the image.

Note:  The Change Object Shape button works only with vector graphics, such as Windows
Metafile (WMF) images and other graphic objects, such as text line objects.  The feature
does not work with raster graphics, such as Windows Bitmapped (BMP) and Paint (PCX)
files or paragraph text.

• Fit to Page .  Lets you view the entire work page for the current document in WebShop.
This feature is most useful when returning to full view.  This feature is not available with
“in-place” edits.

• Zoom In .  Increases the magnification of the Graphic Editor window view.  It uses the
center of the Graphic Editor window as its center point, not the center of a selected object.
Use the vertical and horizontal scroll bars to change the center of the screen to control the
screen display.  This feature is not available with “in-place” edits.

• Zoom Out .  Decreases the magnification of the Graphic Editor window view.  It uses the
center of the Graphic Editor window as its center point, not the center of a selected object.
Use the vertical and horizontal scroll bars to change the center of the screen to control the
screen display.  This feature is not available with “in-place” edits.

• Manual Zoom .  Lets you select the area which you would like to magnify.  When you
select this button, a magnifying button is added to the mouse pointer arrow.  Use the mouse
pointer to draw a dotted-line box around the area you wish to view and release.  So long as
the area enclosed within the dotted-line box is within the defined image area, it is magnified
to fill the screen display.  This feature is not available with “in-place” edits.

• Zoom On Selection .  Lets you zoom in on highlighted text or graphic object.

For example, if you would like to view a piece of Clipart in the image worksheet area in
greater detail—click the object to highlight it; then click the Zoom On Selection button to
view that object in greater detail.  This feature is not available with “in-place” edits.

• Actual Printed Size (1:1) .  Displays the contents of the Graphic Editor window in the
actual size in which it prints.  If you measured with a ruler on the screen and compared it to
the actual size, you may find that the screen display is not a true 1:1 ratio.  This is due to
the manner in which your monitor is set to display.  If you wish your monitor to display a
true 1:1 ratio (that is, display actual printed size), you will have to adjust the monitor
vertical and horizontal scan when using the 1:1 option in WebShop.  See the User Guide
that accompanied your monitor for information on monitor adjustments.  This feature is not
available with “in-place” edits.
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Object Toolbars

Specialized versions of the Object toolbar appear in Graphic Editor depending on what object
you insert from the New Object toolbar or depending upon what object you select for editing.
There are seven different Object toolbars: Text Line , Paragraph Text , Calendar , Chart ,
Drawing , Map Link and Map Link Editing .  The Object Toolbar–Drawing also activates a
secondary toolbar called the Node Edit  toolbar.

Note:  All seven of the Object toolbars have the same display name, “Object.”  To identify
them individually, the convention Object Toolbar–“Object Type” is used.  Depending upon the
object selected or inserted, one of the seven Object toolbars appears.

Object Toolbar–Text Line
The Object Toolbar–Text Line (Figure 1.5) has a number of options for changing the content
and appearance of a text line object.  All of these functions access the Text Line  dialog box.
This dialog box contains four tabs.
Each tab corresponds to one of the
first four toolbar buttons.  Additional
buttons are provided to align your
text within the bounding box.  The
Object Toolbar–Text Line  only
appears when you click Text Line on
the New Object toolbar or when you
click on a Text Line object to select
it.  The operations performed by this
toolbar are available from the Modify
menu or from the Alignment menu.
The toolbar buttons are described below.

••••• Change Text Line Text (Text Tab) .  Edits the text in a text box.

••••• Change Text Line Font (Font Tab) .  Selects the text font, size, and style.

••••• Change Text Colors (Colors Tab) .  Changes the colors used to display text, background,
and borders.

••••• Change Text Effect (Effect Tab) .  Applies a text effect to the text in the text box.  Avail-
able effects range from drop shadows to perspective lines.

••••• Justify .  Aligns text so that it has flush margins on all sides including left, right, top and
bottom.

••••• Align Left .  Aligns text so that it is flush left.

••••• Center .  Aligns text so that it is centered in the text box.

••••• Align Right .  Aligns text so that it is flush right.

••••• Align Top .  Aligns text so that it is aligned at the top of the text box.

••••• Align Vertically .  Aligns text so that it is vertically centered in the text box.

••••• Align Bottom .  Aligns text so that it is aligned at the bottom of the text box.

Figure 1.5 – Object Toolbar
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Object Toolbar–Paragraph Text
The Object Toolbar–Paragraph Text (Figure 1.6) has a number of options for changing the
content and appearance of a Paragraph Text object.  Each function accesses a different dialog
box that is used to complete the function.  The Object Toolbar–Paragraph Text only appears
when you click Paragraph Text on the New Object toolbar or when you click on a Paragraph
Text object to select it.  The operations performed by this toolbar are available from the Format
menu or from the Tools menu.  The toolbar buttons (and the corresponding dialog boxes) are
described below.

••••• Editing Mode .  Lets you enter editing
mode.  Once in editing mode, a flashing
cursor is displayed within the text box.

••••• Background .  Changes the background
color of the text box or to make it transpar-
ent.  This option opens the Frame Proper-
ties  dialog box.

••••• Paragraph .  Changes the paragraph
alignment, spacing, indents, and line
spacing as well as selecting the bullet and
numbering style.  This option opens the Paragraph Properties  dialog box.

••••• Font .  Selects the font, size, and style for the text in the text box.  This option opens the
Choose Web Font  dialog box.

••••• Search .  Searches for a text string in the current document.  This option opens the Find
dialog box.

••••• Replace .  Searches for a text string in the current document and replace it with some
different text.  This option opens the Replace dialog box.

••••• Spelling .  Checks document spelling.  This option opens the Spell Check  dialog box.

••••• Show/Hide .  Turns on (or off) the display of formatting symbols, such as hard and soft
paragraphs, indents, and tabs.

Object Toolbar–Calendar
The Object Toolbar–Calendar (Figure 1.7) has a number of options for changing the content
and appearance of a calendar.  All of these functions access the Calendar dialog box.  This box
contains seven tabs.  Each tab corresponds to a separate toolbar button.  The Object Toolbar–
Calendar only appears when you click Calendar on the New Object toolbar or when you click
on a calendar object to select it.  The operations performed by this toolbar are available from the
Modify menu.  The toolbar buttons are described below.

••••• Change Calendar Type (Type Tab) .  Specifies the calendar type.  There are six different
types from which to choose: yearly, semi-annually, quarterly, monthly, weekly, and daily.

••••• Change Calendar Font (Font Tab) .  Selects the font, size, and style for each element
displayed on the calendar.

••••• Change Calendar Colors (Colors Tab) .  Changes the calendar colors including those used
for the highlighted dates.

••••• Change Calendar Layout (Layout Tab) .  Arranges the months in a calendar in a number

Figure 1.6 – Object Toolbar
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of different layouts.  For example, the months of an
annual calendar may appear down the page or
across the page.

••••• Change Calendar Date (Date Tab) .  Inserts the
calendar dates using your computer’s system date.
If the calendar is an annual calendar, it will start
with January for the current year (based upon your
computer’s system date).  If the calendar is a
monthly calendar, it begins on the first day of the
current month.

••••• Change Calendar Highlighted Days (Highlighted
Days Tab) .  Adds highlighted dates.  These days
are displayed in red in the WebShop work page.  You can also use predefined holidays that
are included with WebShop.  The default is to only highlight Sundays in a calendar.  You
can also use predefined holidays that are included with WebShop.

••••• Change Calendar Weekday Order (Weekday Order Tab) .  Changes the first day of the
week in the calendar.  WebShop calendars by default begin the week with Sunday (the
exception is the weekly calendar that will begin with the current date).

Object Toolbar–Charts
The Object Toolbar–Charts (Figure 1.8) has a number of options for changing the content and
appearance of a chart object.  All of these functions access the Chart dialog box.  This box
contains three tabs.  Each tab corresponds to a separate toolbar
button.  The Object Toolbar–Chart only appears when you click
Chart on the New Object toolbar or when you click on a chart
object to select it.  The operations performed by this toolbar are
available from the Modify menu.  The toolbar buttons are de-
scribed below.

••••• Change Chart Type (Type Tab) .  Specifies the chart type.
There are twenty-one different chart types.  These include
both two-dimensional and three dimensional charts.

••••• Change Chart Style (Style Tab) .  Specifies a style for the X
and Y axis (data labels only) and the Grid style.

••••• Change Chart Colors and Data (Colors and Data Tab) .  Changes the chart colors and the
data associated with each data set.  Use this to enter data, add or delete data rows and
columns, specify data labels and specify the colors associated with each data set.

Object Toolbar–Drawing
The Object Toolbar–Drawing (Figure 1.9) has a number of options for inserting and changing
the appearance of a Drawing object.  The Object Toolbar–Drawing only appears when you click
Drawing on the New Object toolbar or when you click on a Drawing object to select it.  The
operations performed by this toolbar are available from either the Create or Modify menus.  The
Drawing toolbar buttons are described below:

••••• Node Edit Tool .  Lets you select and edit a Drawing object’s image nodes.  It also activates

Figure 1.7 – Object Toolbar
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the Edit Node toolbar.  Use this tool to
reshape the drawing object.  When used,
the cursor changes its appearance and
the object’s image nodes appear.  The
bounding handles associated with the
object’s initial insertion and selection
are unavailable.

••••• Rectangle Tool .  Lets you insert a
rectangular drawing object.  When used,
the cursor changes its appearance.  It is
now ready to insert a Drawing object.  To use this tool, click and drag over a blank area.  A
drawing outline appears.  Release the mouse and the object resize handles appear.  You
may now edit the object as necessary.  To make a perfect square, press SHIFT while you
drag the cursor.

••••• Ellipse Tool .  Lets you insert a elliptical drawing object.  When used, the cursor changes its
appearance.  It is now ready to insert a Drawing object.  To use this tool, click and drag
over a blank area.  A drawing outline appears.  Release the mouse and the object resize
handles appear.  You may now edit the object as necessary.  To make a perfect circle, press
SHIFT while you drag the cursor.

••••• Polygon Tool .  Lets you insert a multisided drawing object.  When used, the cursor
changes its appearance.  It is now ready to insert a Drawing object.  To use this tool, click
once to establish an initial point.  Move your cursor to a new position and click again.  A
line is inserted.  Continue to move the cursor across the image worksheet area while
clicking whenever a connecting line should be inserted.  When done, double-click.  A
dialog box appears with the question:  “Do you want to close the polygon? ”  Click Yes
or No.  If you click Yes, an additional line is inserted between the endpoint of the last line
and the starting point of the first line.  A completed drawing and object resize handles
appear.  If you click No, the object is left open.  You may now edit the object as necessary.

••••• Brush Color .  Lets you specify a color fill for the selected object.  By default, new objects
are inserted with a transparent fill.  When used, a color selection palette appears.  The upper
left square has an X in it.  This is the transparency setting.  At the bottom there is a button
marked MORE.  Click on it and Choose Color  dialog box appears.  Use this dialog box to
specify the predesigned color palette you want to use from the color palette library.

••••• Pen Color .  Lets you specify a line color fill for the selected object outline.  By default,
new objects are inserted with black outline.  When used, a color selection palette appears.
The upper left square has an X in it.  This is the transparency setting.  At the bottom there is
a button marked MORE.  Click on it and Set Default Brush Options  dialog box appears.
Use this dialog box to specify the predesigned color palette you want to use from the color
palette library and to specify the line width.  A setting of zero line width still produces a
visible line that can be seen in a browser.  To make the outline transparent, you must use
the transparency selection.  A transparent outline is not visible in WebShop or in a browser.

••••• Edit Object .  Turns on and off the Edit functionality associated with a Drawing object.
Drawing objects can demonstrate three different bounding box handles:  (1) when selected
as a graphic object without edit functionality available, (2) when initially inserted or
selected and edit functionality is available, or (3) when image nodes are available for edit
(Figure 1.10).  This button toggles on and off Edit functionality.  If an object has been

Figure 1.9 – Object Toolbar
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inserted and subsequently selected for node edit only bounding box handles (1) and (3) are
available (that is, object selection handles or nodes).  If you click once on Edit Object, the
object is ready for Node Edit, if you click again the Object selection handles appear.

Secondary Object Toolbar – Node Edit
The Node Edit toolbar (Figure 1.11) only appears when you click the Node Edit Tool .  Use this
toolbar to manipulate a Drawing object’s bounding area nodes.  Node handles only appear if
you click Node Edit Tool  or Edit Object .  The operations accessed by the Node Edit toolbar are
available from the Modify menu.  The Node Edit toolbar buttons are described below.

••••• Add Node .  Adds a node to the bounding area.  To use this feature, click Node Edit Tool .
The bounding area nodes appear.  Position the cursor over one of the bounding area lines.
The cursor displays a + sign.  Click on the line to
place a selection point on the line.  Click Add Node
and the selection point becomes a node.  You can
now manipulate the line by moving the node.

••••• Delete Node .  Deletes a node from the bounding
area.  To use this feature, click Node Edit Tool .
The bounding area nodes appear.  Select one of the
existing nodes.  Click Delete Node  and the node is
removed.  The existing line is automatically
redrawn to extend between the two remaining
nodes that are directly contiguous.

••••• Convert to Curve .  Converts a linear node to a curve.  To use this feature, click Node Edit
Tool .  The bounding area nodes appear.  Select one of the existing nodes.  Click Convert to
Curve .  The angle created by the node is automatically redrawn to be a curve.

••••• Convert to Line .  Converts a curvilinear node to a line.  To use this feature, click Node
Edit Tool .  The bounding area nodes appear.  Select one of the existing nodes.  Click
Convert to Line .  The angle created by the node is automatically redrawn to be an inter-
secting pair of lines.

••••• Join Nodes .  Joins two or more nodes together.  To use this feature, click Node Edit Tool .
The bounding area nodes appear.  Select two line end-point nodes.  Click Join Nodes .  The
two end-point nodes are brought together and the lines attached to each are redrawn.

Figure 1.11 – Node Edit Toolbar
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••••• Split Nodes .  Splits a node into two independent nodes.  To use this feature, click Node
Edit Tool .  The bounding area nodes appear.  Select one of the existing nodes.  Click Split
Nodes .  The angle created by the node is automatically split and two independent end-point
nodes are inserted.  Use this feature to split a line or to open a closed figure.

••••• Align Nodes .  Aligns the selected nodes either horizontally or vertically.  To use this
feature, click Node Edit Tool .  The bounding area nodes appear.  Select two or more of the
existing nodes.  Click Align Nodes .  The Align Nodes dialog box appears.  Click a vertical
or horizontal alignment option and click OK.  The selected nodes are realigned.  The
realignment that takes place is relative based on the current position of the selected nodes.
If you select Top alignment, the selected nodes will be placed in a line at the position of the
topmost node.  The same holds true for vertical alignment.  Since alignment is relative,
nodes that are already close together will not move much.  Also nodes that are already close
together in vertical or horizontal alignment will “stack up” around the same point.
For example:  If you specify a vertical (left-right) alignment and the selected nodes are
already aligned horizontally (that is they make a horizontal line), the vertical alignment will
cause the selected nodes to become stacked one on top of the other.  When using this
feature, you may want to use a high degree of magnification so approximate positions of
closely aligned nodes is more obvious.

Object Toolbar–Map Link
The Object Toolbar–Map Link (Figure 1.12) has a number of options for establishing map link
areas.  These are the same drawing tools available on the Object toolbar that appear for drawing
objects.  The operations performed by this toolbar are available
from the Create menu which appears when you click the Map
Link  button on the New Object toolbar.  The Map Link toolbar
options include:

••••• Rectangle Tool .  Lets you insert a rectangular map link
area.  When used, the cursor changes its appearance.  It is
now ready to insert a Drawing object.  To use this tool, click
and drag over a blank area.  A drawing outline appears.
Release the mouse and the Link dialog box appears.  Specify
your link, and click OK.  The rectangular map link area
appears in gray with the object resize handles.  The Map
Link Editing toolbar also appears.  You may now edit the link map area as necessary.  To
make a perfect square, press SHIFT while you drag the cursor.

••••• Ellipse Tool .  Lets you insert a elliptical map link area.  When used, the cursor changes its
appearance.  It is now ready to insert a Drawing object.  To use this tool, click and drag
over a blank area.  A drawing outline appears.  Release the mouse and the Link dialog box
appears.  Specify your link, and click OK.  The elliptical map link area appears in gray with
the object resize handles.  The Map Link Editing toolbar also appears.  You may now edit
the link map area as necessary.  To make a perfect circle, press SHIFT while you drag the
cursor.

••••• Polygon Tool .  Lets you insert a multisided map link area.  When used, the cursor changes
its appearance.  It is now ready to insert a Drawing object.  To use this tool, click once to
establish an initial point.  Move your cursor to a new position and click again.  A line is
inserted.  Continue to move the cursor across the image worksheet area while clicking

Figure 1.12 – Object Toolbar
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whenever a connecting line should be inserted.  When done, double-click.  If you have not
closed the link map area an additional line is inserted between the endpoint of the last line
and the starting point of the first line.  The Link dialog box appears.  Specify your link, and
click OK.  The multisided map link area appears in gray with the object resize handles.  The
Map Link Editing toolbar also appears.  You may now edit the link map area as necessary.

Object Toolbar–Map Link Editing
The Object Toolbar–Map Link Editing (Figure 1.13) has a number of options for editing map
link areas and map link URL assignments.  Two of the buttons on this toolbar are the same ones
found on the Object toolbar that appears for drawing objects.  The operations performed by this
toolbar are available from the Modify menu which appears when you click on an image map
area.  The Map Link Editing toolbar options include:

••••• Node Edit Tool .  Lets you select and edit a map
link’s bounding area nodes.  Also activates the Edit
Node toolbar.  Use this tool to reshape the bounding
area nodes.  When used, the cursor changes its
appearance and the map link’s bounding area nodes
appear.  Once you click on this tool, only the
bounding areas resize handles or image nodes will
appear.  The bounding handles associated with map
link’s initial insertion and selection are unavailable.

••••• Edit Object .  Turns on and off the Edit functionality associated with a map link area.  Map
link area can demonstrate three different bounding box handles:  (1) when selected as a
object without edit functionality available, (2) when initially inserted or selected and edit
functionality is available, or (3) when image nodes are available for edit (Figure 1.10).
This button toggles on and off edit functionality.  If a map link area has been inserted and
subsequently selected for node edit, only bounding box handles (1) and (3) are available.  If
you click once on Edit Object, the object is ready for Node Edit, if you click again the Link
dialog box appears.  When this dialog box closes the Object selection handles appear.

••••• Link .  Opens the Link dialog box.  Use this button to update the map link’s URL assign-
ment.

Paragraph Text Formatting
When formatting paragraph text, you could be working with any one of three toolbars: Format-
ting toolbar, Insert Object toolbar, and Object Toolbar–Paragraph Text.  Only the Formatting
toolbar and the Insert Object toolbar are covered here.  (For information about the Object
Toolbar–Paragraph Text, see the topic  “Object Toolbars.”)

Figure 1.13 – Object Toolbar
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Paragraph Text–Formatting Toolbar
The Paragraph Text–Formatting toolbar (Figure 1.14) has a number of options for changing the
appearance of text contained within a paragraph mark.  The buttons and formatting options
available are described below.

••••• Font Pull Down .  Selects the font that you wish to use.

••••• Size Pull Down .  Selects the font size that you wish to use.

••••• Bold .  Bolds the selected text.

••••• Italic .  Italicizes the selected text.

••••• Underline .  Underlines the selected text.

••••• Align Left .  Aligns the selected text so that it is flush left.

••••• Center .  Aligns the selected text so that it is centered in the Paragraph Text box.

••••• Align Right .  Aligns the selected text so that it is flush right.

••••• Justify .  Justifies the selected text.  This option is currently unavailable.

Paragraph Text–Insert Object Toolbar
The Paragraph Text–Insert Object toolbar (Figure 1.15) has a number of options for inserting
formatting in front of any text that is contained within a paragraph mark.  The buttons and
formatting options available are described below.

••••• Text .  Imports text into a document from an external
file.

••••• Bullet .  Inserts (or removes) a bullet at the start of each
currently selected paragraph.

••••• Numbering .  Inserts (or removes) a number at the
beginning of each currently selected paragraph.

••••• Increase Indent .  Increases the indent for the selected
paragraphs.

••••• Decrease Indent .  Decreases the indent for the selected
paragraphs.

Figure 1.15 – Insert Object Toolbar
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Clipart Toolbar

WebShop features a Clipart toolbar  (Figure 1.16) on the right side of the Graphic Editor
window and on the right of the Page Editor window during an “in-place edit.  Unlike the other
toolbars in WebShop that access specific functions, the Clipart toolbar provides drag-and-drop
access to various Clipart images that are stored in Clipart libraries.  You can access several
Clipart libraries and their associated images using the Clipart toolbar.

To select a Clipart library and scroll through the images
1. Click the button located at the top of the Clipart toolbar.  A list of available graphic

libraries appears.
2. Click the desired library to display it in the Clipart toolbar.
3. To scroll through the library images or click the up or down arrow at

the bottom of the toolbar.

WebShop comes with a variety of Clipart libraries.  These include arrows,
balloons, bullets, signs, and others.  The Clipart libraries available on your
PC will depend on the Clipart options you selected during installation.

To place a Clipart image on the image worksheet area
1. Select the Clipart library that you want.
2. Scroll through the images until you find the one you want.
3. Drag and drop the image into image worksheet area.

You can add or delete Clipart images or entire Clipart libraries using
Library > Edit Image Library .

Ruler Setup

WebShop features a ruler that you turn on (or off) using the Preferences dialog box.  If you
have this feature turned on, the ruler displays across the top and left sides of the Graphic Editor.
The upper left corner of the ruler (Figure 1.17) contains a box with which you use to reset the
zero point locations on the Top and Left rulers.  To use this feature, you must have the ruler
option turned on.

To reset a zero point on the Ruler
1. Click the box that is in the corner of the

ruler (where the vertical and horizontal
rulers meet).

2. Click and drag the cursor to the position
on the ruler where you wish the zero point
to be located.

3. Release the mouse button.  The zero point
is reset.

Figure 1.16
Clipart Toolbar
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Chapter 2.
Text Line and Paragraph Text
Objects

Introduction
Text Line and Paragraph Text are two different text objects you create in the Graphic Editor.
These objects can be inserted into the image worksheet area and used as stand-alone images or
with compound images.

Text Line and Paragraph Text Comparison
The New Object toolbar features two different buttons that you use to add text to the image
worksheet area: the text line button and the paragraph text button.

The text line button lets you enter one line of text at a time.  The paragraph text button lets you
enter more than one line at a time.  There are a number of other differences between these text
entry systems:

Text Line Paragraph Text

Enter one line of text Yes Yes
Enter more than one line of text No Yes
Choose text colors Yes Yes
Choose background colors Yes Yes
Specify color for borders on characters Yes No
Import ASCII text from other sources No Yes
Resize the text using mouse controls or Align & Size Yes No
Resize the text by selecting font size No Yes
Align text left, right, center Yes Yes
Apply special/shadow effects Yes No
Apply shape effects Yes No
Text input limited to 128 characters Yes No
Place text horizontally or vertically Yes No
Specify inter-character spacing Yes No
Word-wrap availability No Yes
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Text Line Objects

When you select the Text Line  button on the New Object toolbar, the Text Line dialog box
appears.  Use this dialog box to specify your Text line attributes.   Once the Text line is inserted.
The Text Line Object toolbar appears.

Text Line Dialog Box
Text Line  dialog box (Figure 2.1) has four tabs.  Use this to specify the text, font, color and
effects to apply.  Alignment within the text line bounding box is controlled through the Text
Line toolbar or by menu command.

••••• Text .  From this tab, enter up to 128 characters of text, select whether to use horizontal or
vertical placement, and enter a specified amount of spacing between characters.

••••• Font .  From this tab, select a font to use.

••••• Colors .  From this tab, select a color library and colors to apply with background, character
symbols, and shadow effects.  Separate colors can be specified for the outline and fill.

••••• Effects .  From this tab, select an effects library or use a predesigned effect, specify the
effect control.  This could include a slant grade, rotation percentage, or horizontal or
vertical shifts.  The effects control section is selection specific.

Figure 2.1 – Text Box Dialog Box
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Text Line Toolbar and  Menu Options
Use the Object Toolbar–Text Line (Figure 2.2) to edit a text line object.  Two additional menus
appear (Figure 2.3) on the menu toolbar whenever a text line object is inserted or selected.

Inserting and Editing Text Line Objects
Text Line objects have several elements:  content, font, font color, one or more text effects, and
bounding box shape.  When inserting a Text Line into a Web site project be aware of all of
these elements.  This is particularly true when creating a text line slot.  To maintain your design,
replacement text should fill the bounding box space allocated.

To insert a text line
1. Select Object > Add > Text Line , or click the Text Line  button.  The Text Line  dialog box

appears.
2. Type your text and specify the alignment and character spacing as necessary.
3. When done, click OK.  The Graphic Editor window reappears.  The object is inserted.
4. To deselect the object, click outside the box.  The object bounding box disappears.

To edit a text line object using the Object toolbar
1. Click the text line object you want to edit.  The object bounding box and the Object toolbar

appears.
2. Decide what you want to do:

• To edit the text, click Change Text Line Text  on the Text Line Object toolbar or select
Modify > Text .

• To change the text font, click Change Text Line Font  on the Text Line Object toolbar
or select Modify > Font .

• To change the text color, click Change Text Line Colors  on the Text Line Object
toolbar or select Modify > Colors .

• To change the text effects, click Change Text Line Effects  on the Text Line Object
toolbar or select Modify > Effects .

Figure 2.2 – Object Toolbar
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Figure 2.3 – Text Line Menu Options
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Note:  The Text Line dialog box appears with a different dialog box tab selected depending
upon which button you select.

3. Specify your changes using the Text Line  dialog box fields and buttons as necessary.
4. When done, click OK.  The text line object is updated.

To align the text line text within the bounding box
1. Click the text line object you want to edit.  The object bounding box and the Object toolbar

appears.
2. Decide what you want to do:

• To specify the horizontal alignment, click Align Left , Align Right  or Center Horizon-
tally  on the Text Line Object toolbar or select Alignment and specify the menu option
that you want.

• To specify the vertical alignment, click Align Top , Align Bottom or Center Vertically
on the Text Line Object toolbar or select Alignment and specify the menu option that
you want.

• To provide equal spacing in all directions, click Justify on the Text Line Object
toolbar or select Alignment > Justify .

Note:  You will still need to align this object with your existing Web page text once it is
inserted onto a Web page.

3. To deselect the object, click outside the box.  The object bounding box disappears.

Paragraph Text Objects

When you select Paragraph Text on the New Object toolbar, an empty text box is inserted and
three toolbars appear: the Formatting toolbar, the Insert Object toolbar, and the Paragraph Text
Object toolbar. By default, a paragraph
text object is sized to fit the entire image
worksheet area.

To insert text you must be in the edit text
mode.  Select Format > Edit Text  or click
Edit Text  on the Object Toolbar–Para-
graph Text to toggle the edit text mode on
or off.  When the edit text mode is on, a
blinking cursor appears within the text
box.  Type the text you want.

To format the text inserted use the
Paragraph Properties dialog box (Figure
2.4) or the Choose WEB Font  dialog box
(Figure 2.5).  To specify a background
color, use the Frame Properties  dialog
box.

Figure 2.4 – Paragraph Properties Dialog Box
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Paragraph Properties  Dialog Box
Use the Paragraph Properties dialog box (Figure 2.4) to format paragraph text.  The Para-
graph Properties  dialog box has three tabs.

••••• General .  From this tab, select an HTML style to apply; specify the text wrap and align-
ment of the text within the bounding box; specify the line spacing and any before, or after,
paragraph spacing; specify the left and right margins and paragraph indentations.

••••• Bulleting .  From this tab, you may turn on and off bulleting; select a type of bullet; import
or create a custom bullet.  The bullet color
and size defaults from the HTML font
selected.

••••• Numbering .  From this tab, you may turn
on and off numbering; select a numbering
style and separator; set a manual value.
The numbering color and size defaults from
the HTML font selected.

Choose WEB Font  Dialog Box
Use the Choose WEB Font  dialog box (Figure
2.5) to format the inserted text.   This dialog box
allows you to specify the text color and text
background color.  You can also assign text
effects and font styles.  Several of these features
are replicated in the Paragraph Properties
dialog box and on the Formatting toolbar.

Note:  The text background color is not the
same as the background color for the
Paragraph Text object.

Frame Properties  Dialog Box
Use the Frame Properties dialog box (Figure
2.6) to specify a background color for the entire
Paragraph Text object.  Select a color palette
from the Color Library  drop down box.  If you
select transparent, the Web page background
will be seen.  To insert a border around the
Paragraph Text object, use Image Attributes
(which frames the entire image worksheet area)
or draw a border and group the two objects
together.

Paragraph Text Toolbars and  Menu Options
The toolbars that appear whenever a paragraph text object is inserted or selected include the
Formatting toolbar (not shown), the Insert Object toolbar (Figure 2.7), and the Object Toolbar–
Paragraph Text (Figure 2.8).  Use these toolbars to edit a paragraph text object.  Four additional

Figure 2.6 – Frame Properties Dialog Box

Figure 2.5 – Choose WEB Font Dialog Box
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menus (Figure 2.9) also appear on the menu toolbar whenever a text line object is inserted or
selected.

Inserting and Editing Paragraph Text Objects
To insert a paragraph text object
1. Select Object > Add > Paragraph Text  or click Paragraph Text  on the New Object

Toolbar.  The image bounding box handles change and paragraph text toolbars appear.

Note:  By default, a newly inserted Paragraph Text object is automatically the same size as
the image worksheet.  Once you add text, you can resize it as you want.  If not all of the text
is visible, you may need to enlarge the image worksheet using Page Setup on the Main
toolbar.

To insert text
1. Double-click image box and begin typing.
2. When done, click outside the box.  The paragraph object is deselected.

To edit text
• Click Edit Mode  on the Paragraph Text Object toolbar, or select Format > Edit Text .  A

blinking cursor appears within the text box at its last position.  You are now in edit mode.

Figure 2.9 – Paragraph Text Menu Options

Figure 2.8 – Object Toolbar
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To exit edit mode
• Select Format > Edit Text  or click Edit Text  on the Object again.  The blinking cursor

disappears and the paragraph object remains selected.

To resize a Paragraph Text object
1. Select the Paragraph Text object.  An object selection box appears with resize handles on

the corners and sides.
2. Move the mouse into the object area.  The object selection box begins to blink.
3. Click and drag the bottom center sizing button.  The object selection box gets either bigger

or smaller.
4. When done, release the mouse to set the size.  The object is resized.
Repeat this procedure on each sizing button until all of the text is displayed.

To add paragraph text attributes
1. Click Edit Mode  on the Paragraph Text Object toolbar or select Format > Edit Text .  A

blinking cursor appears within the text box at its last position.  You are now in edit mode.
2. Select the text you want to change.
3. Decide what you want to do:

• To insert formatting from the Insert Object toolbar, select one of the following buttons:
bullets, numbering, increase indent, or decrease indent, or select one of the Insert
menu options.

• To apply formatting from the Formatting toolbar, select one of the following buttons:
bold, italic, underline, align left, align right, center, or select one of the menu options
from either Effects or Format .

• To apply formatting using the Paragraph Properties dialog box, click Paragraph on
the Object toolbar or select Format > Paragraph .  The Paragraph Properties  dialog
box appears.  The General tab is selected.  Change any of the attributes you want.
When done, click OK.

Note: Unless you select all of the text in the Paragraph Text object, the formatting will apply
to the selected text only.

• To apply character formatting using the Choose WEB Font dialog box, click Font on
the Object toolbar or select Format > Font .  The Choose WEB Font  dialog box
appears.  Change any of the attributes you want. When done, click OK.

To change the background color of the Paragraph Text object
1. Click the Paragraph Text object that you want to change.  The image bounding box handles

and paragraph text toolbars appear.
2. Click Background on the Object toolbar or select Format > Background .  The Frame

Properties dialog box appears.

Note:  By default a newly inserted Paragraph Text object has a transparent background.

3. Select a color library from the Library drop-down list box.
4. Select the color you want to use.
5. Click OK.  The background color is updated.



Chapter 3 .
Fill Pattern Objects

Introduction

Fill Pattern objects are objects you create in the Graphic Editor.  These objects are placed in the
image worksheet area and are used to create stand-alone images or compound images.  A fill
pattern is a pattern (or color) that covers the entire print area of a graphic object.  It is a separate
image “layer” that you place behind your central graphic.  Fill patterns are separate objects that
you select and manipulate like other graphic objects.  You will want to create these to create
multilayered images.

The Fill Pattern  button on the New Object toolbar provides a quick and easy method for placing
fill patterns in or behind a graphic object.  Use the Fill Pattern dialog box to make your
specifications.

Fill Pattern Dialog Box
The Fill Pattern  dialog box (Figure 3.1) has three tabs.
Each tab controls the options associated with a
different Fill Pattern.

••••• Color .  Use this tab to create a color fill.  You can
specify a blended or patterned set of colors.  There
are seven different color “fill types.”  Use the
Sample library to store additional “fill types” as
you develop them.

••••• Brush .  Use this tab to create a brush fill.  You
can choose a brush pattern from a number of
brush pattern libraries.  Use these libraries to
create either black and white, color, or semi-
transparent effects.

••••• Picture .  Use this tab to create a picture fill.  You can choose a picture pattern from a
number of picture libraries.  Use these libraries to create either black and white, color, or
semi-transparent effects.  You can also import your own picture.

Figure 3.1 – Fill Pattern Dialog Box
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Fill Pattern Options
Color Fill  Options .  When you select the color tab in the Fill Pattern dialog box, the box
expands to display the Filler and Color Mix  options.  The Sample area displays a graduated
color scale which displays the range of color based upon the color combination in effect.  To
select a different pattern, click the down arrow next to the Filler combo box.  You can select
from the following Filler patterns: Strips , Circles , Sectors 1 , Sectors 2 , Rectangles , Arcs ,
Tangents , and Lines .

You can select the colors for the background pattern by designating the first and last colors to
be used in the pattern.  Many of the patterns are graduated with one color slowly blending into
another.  You can designate the colors to use by designating the First Color  and the Last Color
from the colors in the Color Bar  scroll box.  To do this, select either the First Color option or
the Last Color option in the lower left corner of the Fill Pattern  dialog box.  Next, click the
desired color combination in the Color Bar  scroll box.  The selected fill color (that is, first or
last color) will change to the selected color.  If desired, you can mix colors from different color
combinations.  For example, you can select a color from the Default palette for the First Color
and select a color from the Blue Palette for the Last Color .

Fill Pattern Options .  Additional options in the Fill Pattern  dialog box deal with the manner in
which the colors blend.  These options provide control over how the colors are blended in the
background fill pattern.
• Symmetric .  The default color in the background pattern fill is to blend from one color to

another.  The Symmetric option blends the pattern from the first color to the last color and
back to the first color.

• Count .  The Count option scroll list controls the number of lines or graduations that are
displayed in the fill pattern.  For example, a Count of two displays just two solid colors: the
first color and the last color (that is, there are only two graduations between the two colors).
You can use the scroll arrow to change the count or you can delete the number in the scroll
box and type the desired number.

• Angle .  The Angle option controls the angle at which the graduated lines appear in the
background fill pattern.  A zero angle displays the graduated lines horizontally.  A 45-
degree angle displays the graduated lines diagonally.  A 90-degree angle displays the
graduated lines perpendicular to the screen.

• Line Width .  The Line Width option is only available for the Tangent and Lines selections
in the Filler scroll box.  The Line Width option enables you to change the width of the lines
in the fill pattern when the appropriate Filler is selected.

Pictures as Fill Patterns .  You can use pictures or Clipart to make up a fill pattern in Web-
Shop.  You can use an image included in the WebShop Pictures pattern selection or you can
create a pattern library of your own Clipart.  The appearance of the picture fill patterns can be
controlled by changing the size of the image in the pattern.

Pattern Fill Menu Options
Once you create a fill pattern object and place it in the image worksheet area, it is treated just
like any other object.  To edit this object, select Modify > Properties .  There is only one
command off the Modify menu.
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Inserting and Editing Fill Pattern Objects

To insert a fill pattern
1. Select Object > Add > Fill Pattern , or click Fill Pattern  on the New Object toolbar.  The

Fill Pattern  dialog box appears.
2. Decide what you want to do:

• To insert a color fill, click the Color tab  (Figure 3.2) and make any additional specifi-
cations to create additional effects.

Note:  For more information about color fill effects, see the topic “Editing Color Fills.”

• To insert a brush fill, click the Brush tab  (Figure 3.1) and make any additional
specifications to create additional effects.

Note:  For more information about brush fill effects, see the topic “Editing Picture and Brush
Fills.”

• To insert a picture fill, click the Picture tab (Figure 3.3) and make any additional
specifications to create additional effects.

Note:  For more information about picture fill effects, see the topic “Editing Picture and Brush
Fills.”

3. When done, click OK.  The selected fill pattern covers the entire work area.

Editing Color Fills
The program’s Color Fill feature is very flexible.  Use it to create solid color fills, blended color
fills, color “pattern” fills.  You are also able to change the center point used to create the color
pattern fills.  The procedures used to create blended color fills or color “pattern” fills is very
similar to the ones used to solid color fills.  Use the following procedures to edit or create color
fills.

Note:  To edit a color fill that has already been inserted, double-click the fill pattern object in
the Graphic Editor window.  The Fill Pattern dialog box appears  (Figure 3.2).

To begin using color fills
1. To quickly create an interesting color fill, click on

the Sample Library  drop-down box, select a
sample color fill.

Note:  These samples use each of the eight fill
types.

2. To specify your own fill, click on the Fill Type
drop-down box and select the fill type you want to
use.

3. To specify your own color palette, click on the
Color Library  drop-down box and select the Color
Palette  option you want to use.

Figure 3.2 – Color Fill Tab
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To create a solid color fill
1. Click Filler drop-down list and select a Filler other than Lines and Tangent .

Note:  The Filler patterns, Line and Tangent use a white background and therefore cannot
be used to create a solid color fill.

2. Click First Color  box.  The First Color box outline is highlighted.
3. Select the color that you want from the displayed color palette.
4. Click Last Color  box.  The Last Color box outline is highlighted.
5. Select the same color that you selected for the first color.  The sample areas shows a solid

color fill.

To create a Blended color fill
1. Click the Filler drop-down list and select a Stripes .

Note: By default the Color Mix is Off, the number of Lines is 95, the angle setting is zero,
and Symmetric check box is checked

2. Click First Color  box.  The First Color box outline is highlighted.
3. Select the color that you want from the displayed color palette.
4. Click Last Color  box.  The Last Color box outline is highlighted.
5. Select the different color than you selected for the first color.  The sample area shows a

blended color fill that starts with first color blends to the last and blends back to the first.
6. To change the blending, deselect the Symmetric check box.  The sample areas shows a

blended color fill that starts with first color blends to the last color only.

To change the center or symmetry point

For some types of color fills, you can move the center point to create different effects.
1. Click the Filler drop-down list and select a pattern that uses the center point feature.

Note:  The only fill patterns that do not use this feature are Rectangles, Stripes, Arcs, and
Lines.  Each of these patterns requires a fixed center point ratio.  Look for the display
message: “Drag the mouse in the center to mutate the center” to identify color fills that can
be adapted.

2. Position your cursor in the sample area and click.  Two cross-lines appear.
3. Move the cursor to the center point position that you want and release.  The pattern now

reflects a new center point position.

Editing Picture and Brush Fills
Picture fills  (Figure 3.3) and Brush fills (Figure 3.1) are created from the Clipart and brush files
that were installed with your program.  You can add pictures by creating or adding your own
Clipart library (see the chapter titled “Editing WebShop Libraries” in the User Guide).  With
Picture and Brush fills, you will want to control the size of the picture or brush image imported
into the Graphic Editor window and determine if you want to maintain the aspect ratio (that is,
the vertical and horizontal relationship) once the fill is imported into the Graphic Editor.

Note:  To edit a Picture fill from the Graphic Editor window, double-click fill pattern object.
The Fill Pattern dialog box appears (Figure 3.3).  The edit procedure for both Brush and Picture
fills are virtually identical.
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To size the picture or brush image that you want to import
1. Click the Picture or Brush drop-down list and select a Brush or Picture library.
2. Select the picture or brush image that you want from the preview images displayed.  A

larger scale image appears in the Sample area.  The message: “Drag the mouse in the
sample to define the size of one picture ” appears.

3. Position your cursor in the upper left-hand corner
of the Sample area and click.  Two perpendicular
lines appear.

Note:  These lines are used to define a picture or
brush pattern size base upon the ratio of the two
sides.  To make the pattern bigger (in equal
proportion), move the cursor from the upper left to
the lower right.  To make the pattern bigger and
wider, move the cursor to the cursor to the right
only.  To make the pattern bigger and taller, move
the cursor to the bottom only.  To reset the pattern,
click the preview sample from the drop-down list
again.

4. Move the cursor to ratio position you want and
release.  The pattern now appears bigger.

To set the aspect ratio prior to importing the
picture or brush image
1. Once your fill pattern is ready to be imported, click the Keep Size and Aspect Ratio  check

box.
2. Click OK to import the fill pattern object into the Graphic Editor window.  The Fill Pattern

object fills up the entire screen.

Note:  You can now resize the fill box in anyway you want.  The size and aspect ratio of the
Picture or Brush pattern image will not be affected.

Figure 3.3 – Brush and Picture Fill Tab
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Calendar and Chart Objects

Introduction
Calendar and Chart Objects are objects you create in Graphic Editor.  These objects are placed
in the Graphics Editor window and are used to create stand-alone images or compound images.
You will want to create these whenever it is important to reference calendar dates on a Web
page or whenever you want to graphically present data in a chart.

Topics covered in this chapter include:
• Setting Your Calendar Options
• Calendar Toolbar and Menu Options
• Inserting and Editing Calendar Objects
• Setting Your Chart Options
• Chart Toolbar and Menu Options
• Inserting and Editing Chart Objects

Calendar Objects

The Calendar feature of WebShop lets you insert a variety of different calendars.  To set up a
calendar, select  Object  > Add  > Calendar , or click Calendar  on the Calendar Object toolbar.
The Calendar  dialog box appears.

Setting Your Calendar Options
The following describe the different tabs of the Calendar  dialog box (Figure 4.1).  Use these
tabs to design or modify calendars.

Setting  Calendar  Type .  The Type  tab assigns a different calendar type.  WebShop supports six
types of calendars: yearly, semi-annually, quarterly, monthly, weekly, and daily.  Select the type
of calendar you want and click OK.

Setting  Calendar  Fonts .  The Fonts  tab assigns different font styles and sizes to different parts
of the calendar.  This tab provides you with the options to set the fonts for the days, the months,
the years of the calendar.  Set the fonts that you want and click OK.

Setting  Calendar  Colors .  The Colors  tab sets the colors you want for different parts of the
calendar.  Set the colors you want, and click OK.
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Setting  Calendar  Day Order .  The Options  tab sets the day of the week you want your
calendar to start from.  In other words, your calendar does not have to start from Monday or
Sunday.  You can set it to start from any day of the week.  You can also set the calendar
orientation (vertical or horizontal).  You can set orientation options only for yearly, semiannu-
ally, quarterly, or monthly calendars.  For monthly calendars, you can also fill the unused
positions (or the blank days of the current month) with the days of the previous, or with next
month’s—by adding the next or previous month’s days in a small size to your current calendar.
Choose the day order you want and click OK.

Setting  Calendar  Date.  The Date tab sets the dates for the calendar.  Different calendar types
have different options.  Select the year, the starting and the ending date for the calendar.  To
apply the current date (from your computer) to the calendar, click Current.  Choose the dates
you want, and click OK.

Setting  Highlighted  Days .  The Highlighted  Days  tab sets your calendar-highlighted days to
be different colors than the rest of the days.  Use this tab for all calendar types except the daily
calendars.

The different highlighting options are:

••••• Highlight  regular  days .  For example: highlight all Sundays.
••••• Highlight  fixed  days .  For example: designate May 1 and July 4 as special dates.
••••• Highlight  floating  days .  For example: the last Monday of October.

Use this tab to create different lists of highlighted days.  Name them and add them to the sets of
highlighted days.  For example, in the first list (Friends) you can keep the birthdays of your
friends (use fixed days highlight); in the second (Games) you can keep the dates for the games
of your favorite team (use floating days highlight if, for example, they play on Wednesdays).

Figure 4.1 – Calendar Dialog Box
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Later you can create a calendar with these highlighted days by simply choosing Friends or
Games from the Sets of Highlighted Days.  Set the highlighted days and click OK.

Setting  Calendar  Layout .  The Layout tab sets horizontal, vertical, and other monthly arrange-
ments.  You can also set the order of the months to be either horizontal or vertical.  Select the
layout and click OK.

Calendar Toolbar and Menu Options
Use the Object Toolbar–Calendar (Figure 4.2) to edit a calendar object.  One additional menu
(Figure 4.3) appears on the Menu bar once a calendar object is inserted.  The Modify functions
are the same as the toolbar functions.

Inserting and Editing Calendar Objects
To insert a calendar object
1. Select Object  > Add  > Calendar , or click Calendar  on the Calendar Object toolbar.  The

Calendar  dialog box appears.
2. Specify what type of calendar you want and the display options that you want.

Note:  By default the following display options are checked for you: yearly calendar, rectan-
gular layout, 3x4 arrangement.

3. When done, click OK.  The Calendar Object is inserted.

To edit a Calendar object
1. Click on Calendar object.  The object selection box and Calendar Object toolbar appears.
2. Decide what you want to do:

••••• To edit the calendar type, click Change  Calendar  Type  on the Calendar Object toolbar
or select Modify  > Type .

••••• To change the text font, click Change  Calendar  Font  on the Calendar Object toolbar
or select Modify  > Font .

Figure 4.3 – Calendar Object
Menu  Options
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••••• To change the text colors, click Change  Calendar  Colors  on the Calendar Object
toolbar or select Modify  > Colors .

••••• To edit the calendar layout, click Change  Calendar  Layout  on the Calendar Object
toolbar or select Modify  > Layout .

••••• To change the calendar dates, click Change  Calendar  Dates  on the Calendar Object
toolbar or select Modify  > Dates .

••••• To change the highlighted days, click Change  Calendar  Highlighted  Days  on the
Calendar Object toolbar or select Modify  > Highlighted  Days .

••••• To change the weekday order, click Change  Calendar  Weekday  Order  on the
Calendar Object toolbar or select Modify  > Weekday  Order .

Note:  The Calendar dialog box appears with a different dialog box tab selected depending
upon which option you select.

3. Specify your changes using the dialog box fields and buttons as necessary.
4. When done, click OK.  The calendar object is updated.

Chart Objects

The Chart feature of WebShop lets you insert a variety of different charts.  To set up a chart,
select  Object  > Add  > Chart , or click Chart  on the Chart Object toolbar.  The Chart  dialog box
appears.

Setting Your Chart Options
The following describe the different tabs of the Chart  dialog box (Figure 4.4).  Use these tabs to
design or modify charts.

••••• Setting  Chart  Type .  The Type  tab assigns a different chart type.  WebShop supports
twenty-one chart types, including pie charts, 3D charts, ribbon charts and two-dimensional
charts.  Select the type of chart you want and click OK.

••••• Setting  Style  Fonts .  The Style  tab assigns different Grid and Label styles to either the X
or Y axis.  Set the styles that you want and click OK.

••••• Setting  Chart  Colors  and  Data.  The Colors  and  Data tab sets the data that is used to
create the chart and allows you to specify the colors associated with individual data sets.
You can insert and delete data rows or columns.  If you choose to add rows or columns,
they are appended to the data table rather than inserted between existing columns.  To set
the colors you want, click Colors .  The Colors dialog box appears.  Use the color swatches
to select the data set that you want.  You can also use the Background swatch to change the
grid area background.  When done, click OK.
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Chart Toolbar and Menu Options
Use the Object Toolbar–Chart (Figure 4.5) to edit a chart object.  One additional menu (Figure
4.6) appears on the Menu bar once a chart object is inserted.  The Modify functions are the
same as the toolbar functions.

Figure 4.4 – Chart Dialog Box

Figure 4.6 – Chart Object
Menu Options

Figure 4.5 – Object Toolbar
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Inserting and Editing Chart Objects
To insert a chart object
1. Select Object  > Add  > Chart , or click Chart  on the Chart Object toolbar.  The Chart  dialog

box appears.
2. Specify what type of chart you want and the display options that you want.

Note:  By default the following display options are checked for you: clustered bar with
medium sized labels and four default data sets already inserted.

3. When done, click OK.  The chart object is inserted.

To edit a chart object
1. Click on Chart object.  The object selection box and Chart Object toolbar appears.
2. Decide what you want to do:

• To edit the chart type, click Change  Chart  Type  on the Chart Object toolbar or select
Modify  > Type .

• To change the text font, click Change  Chart  Style  on the Chart Object toolbar or
select Modify  > Style .

• To change the text colors, click Change  Chart  Colors  and  Data on the Chart Object
toolbar or select Modify  > Colors  and  Data.

Note:  The Chart dialog box appears with a different dialog box tab selected depending
upon which option you select.

3. Specify your changes using the dialog box fields and buttons as necessary.
4. When done, click OK.  The chart object is updated.
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